In 4 stappen WordPress 3.9 & 4.0 probleem met qTranslate oplossen

WordPress 3.9.1 is sinds april een feit. Verbeteringen in onder andere de Visual Editor en Widget Interface zijn natuurlijk hartstikke fijn. Maar voor een ieder die een site in meerdere talen had, was het paniek geblazen. Waarom? qTranslate ging raar doen!
wordpress 3.9 qtranslate
qTranslate kon niet goed overweg met de update van WordPress. Mensen die WordPress 3.9.1 installeerden zagen de melding:

The qTranslate Editor has disabled itself because it hasn’t been tested with your WordPress version yet. This is done to prevent WordPress from malfunctioning. You can reenable it by clicking here (may cause data loss! Use at own risk!). To remove this message permanently, please update qTranslate to the corresponding version

Maar dat updaten kon helaas niet. Tegelijkertijd lijkt de maker van qTranslate van de aardbodem verdwenen. Van zijn kant kunnen we dus geen hulp verwachten. Mensen die toch tegen deze waarschuwing qTranslate gingen gebruiken in WordPress 3.9.1 hebben gezien hoe het hun site overhoop bracht; Wat nu?

mqTranslate

Ter vervanging van qTranslate kwam mqTranslate, een afsplitsing die is gemaakt door de code van qTranslate over te nemen. De mqTranslate plugin werkt in de basis hetzelfde als het oude qTranslate. De developer van mqTranslate (Xhaleera) had behoefte aan meer functies die niet in de standaard Qtranslate zaten. Wij hebben zelf mqTranslate nog niet getest en kunnen jullie derhalve nog niet vertellen of het een goede permanente vervanging is.
Als je het toch wilt proberen moet je bij Nieuwe plugin zoeken naar “mqtranslate” van ontwikkelaar Xhaleera. Deactiveer eerst de oude qTranslate plugin, installeer daarna het alternatief. Vergeet daarna niet de talen te activeren die je gebruikte op je site. Mqtranslate is volgens compatible t/m WordPress 4.0

qTranslate Plus

Een andere gemodificeerde versie van qTranslate is qTranslate Plus. De laatste versie van deze plugin is compatible met WordPress 3.9 – 3.9.1 – 3.9.2 en 4.0

Hoe qTranslate te updaten voor WordPress 3.9.1 en WordPress 4.0

qTranslate fixen

GitHUB is een online community waar developers samenkomen om problemen op te lossen. Daar zijn een aantal mensen bezig geweest met de oplossing van het probleem: Interessante discussie (vooral voor developers). Omdat we niet allemaal developers zijn heeft een gebruiker van GitHUB Nsorosac de oplossingen samengevoegd tot een werkende plugin. Deze fix is ontstaan uit de oplossing van mqTranslate, maar pakt het probleem meer head-on aan. Daarbij was hij 1 oplossing vergeten die wij voor jullie eraan toegevoegd hebben in de onderstaande file.

  1. Maak een volledige backup van je WordPress-site (via FTP). Hulp hierbij nodig? Raadpleeg ons.
  2. Ga vanuit het Dashboard naar de Plugins en deactiveer de qTranslate plugin.
  3. Download de fix voor qTranslate op WordPress.
  4. Ga naar Nieuwe plugin en klik op Upload. Ga naar de map waar je de .zip hebt gedownload. Installeer en activeer deze plugin.
  5. Activeer de talen die je gebruikte op je site in de taal instellingen. Sla de instellingen op en het hoort weer te werken!

Let op: Wij zijn niet de makers van deze oplossingen en hebben ze enkel voor jullie gemak samengevoegd. Wij zijn niet aansprakelijk voor problemen die zich voordoen bij het gebruik van deze plugin. Vergeet vooral niet een volledige backup te maken van uw WordPress-site, voordat u deze fix probeert.
 

Geplaatst in Blog, Nieuws, Usability, Wordpress.

Freek Keesen

Andere berichten